HUOM! Voit itse lisätä ja muuttaa sisältöä muokkaa-painikkeiden avulla

 Olet itse vastuussa tämän teoksen käytöstä aiheutuvista vahingoista Lue lisää.

Viitenumero

Kohteesta Wikikko - kansan taitopankki
Loikkaa: valikkoon, hakuun

Netissä sijaitsee Viitenumerolaskin osoitteessa http://www.rajapinta.net/?sivuid=10

Oheinen kaava laskee laskuissa käytettävän viitenumeron. Voit lisätä sen esimerkiksi omaan Excelillä tai OpenOfficella tai NeoOfficella jne. tekemääsi laskupohjaan.

A 59 -A67 ovat soluja, jotka voit määritellä mille numeroille vain, mutta tuossa järjestyksessä toimii.

J9 -solussa sijaitsee laskettava laskunnumero.

Excel[muokkaa]

A59 =POIMI.TEKSTI(J9;PITUUS(J9);1)*7
A60 =JOS(PITUUS(J9)>1;POIMI.TEKSTI(J9;PITUUS(J9)-1;1)*3;0)
A61 =JOS(PITUUS(J9)>2;POIMI.TEKSTI(J9;PITUUS(J9)-2;1)*1;0)
A62 =JOS(PITUUS(J9)>3;POIMI.TEKSTI(J9;PITUUS(J9)-3;1)*7;0)
A63 =JOS(PITUUS(J9)>4;POIMI.TEKSTI(J9;PITUUS(J9)-4;1)*3;0)
A64 =JOS(PITUUS(J9)>5;POIMI.TEKSTI(J9;PITUUS(J9)-5;1)*1;0)
A65 =SUMMA(A59:A64)
A66 =PYÖRISTÄ.KERR.YLÖS(A65;10)-A65
A67 =KETJUTA(J9;A66)*1

NeoOffice Calc ja OpenOffice Calc[muokkaa]

A59 =MID(J9;LEN(J9);1)*7
A60 =IF(LEN(J9)>1;MID(J9;LEN(J9)-1;1)*3;0)
A61 =IF(LEN(J9)>2;MID(J9;LEN(J9)-2;1)*1;0)
A62 =IF(LEN(J9)>3;MID(J9;LEN(J9)-3;1)*7;0)
A63 =IF(LEN(J9)>4;MID(J9;LEN(J9)-4;1)*3;0)
A64 =IF(LEN(J9)>5;MID(J9;LEN(J9)-5;1)*1;0)
A65 =SUM(A59:A64)
A66 =CEILING(A65;10;1)-A65
A67 =CONCATENATE(J9;A66)*1