HUOM! Voit itse lisätä ja muuttaa sisältöä muokkaa-painikkeiden avulla

 Olet itse vastuussa tämän teoksen käytöstä aiheutuvista vahingoista Lue lisää.

TurboCAD Mac

Kohteesta Wikikko - kansan taitopankki
Loikkaa: valikkoon, hakuun

Yleistä[muokkaa]

TurboCAD Mac Deluxe 2D/3D v4 on kaupallinen suunnitteluohjelma Mac-tietokoneelle. Tällä sivulla on ohjeita, kuinka ohjelmaa käytetään aloittelevan näkökulmasta ja vinkkejä ehkä myöhemmin pitemmälle ehtineelle.

Vinkkejä[muokkaa]

  • VAROITUS: Ohjelma sekoilee tallennuksen kanssa ajoittain niin että tiedosto saattaa vioittua ja samalla TurboCAD kaatuu. Tällöin menetetään tiedosto ja jos varmuuskopiota ei ole niin... Tallenna välillä Save as.. -uusi versio ja erityisesti varo jos korvaat aiempaa tiedostoa uudelleen päälle kirjoittamalla.
  • Kun delete näppäin ei poista haluttua kohdetta klikkaa Edit object ruudussa Attributes-valikko näkyviin. Geometry valikossa poistaminen ei onnistu.

1. Käyttöliittymä User Interface[muokkaa]

Ruudun kohteet[muokkaa]

  • Title Bar. Ikkunan ylin raita. Aktiivisen dokumentin nimi.
  • Menu Bar. Valikot kuten File jne. Katso tarkempi kohta alla omalla otsikolla.
  • Tool Palette. Työkalupaletit. Piirto ym. työkalut paletteina ja ikoneina niissä. Hiiren pitäminen ikonin päällä antaa lyhyen kuvauksen (päälle ja pois /Preferences General)
  • Pointer. Osoitin jota hiirellä liikutetaan.
  • Axis. Ruudun keskellä. Näyttää senhetkisen katsontasuunna xyz-koordinaatteina suunnan ruudun keskellä. Voidaa kytkeä päälle tai pois View/Show Axis ja kokonaan Pref/General/Axis
  • Location Indicator. xyz koordinaatit osoittimelle (Pointer). Lähtöpiste (0,0,0) keskellä ruutua.
  • Message Line. Valikon (Menu Bar) alla. Käytössä olevan työkalun nimi ja ohjeet sen käytöstä.
  • Drawing Area. Piirtoalue. Kuvittele rajoittamattoman kokoisena paperina johon voidaan piirtää todellisessa koossa.
  • Scroll Bars. Piirtoalueen skrollaus painikkeet sivulla ja alhaalla. Kelaa nuolilla tai paina niiden välissä jolloin piirtoalue liikkuu suhteellisesti.
  • Status Line. Alhaalla vasemmalla. Koordinaattien sijainti ym. tietoa senhetkisestä objektista Maailman koordinaattijärjestelmässä. Hiirellä aktivoidaan arvo, arvoja voi muuttaa näppäimistöltä, sarakenäppäimellä liikutaan toiseen arvoon, enter hyväksyy. Desimaalien määrä säädetään Preferences/Units/Precision. Rivin lukuja voi kopioida cmd+c ja cmd+v. Kenttiin voi myös syöttää matemaattisia, trigonometrisiä ja ekponentiallisia funktioita (lista s. 13-14).
  • Coordinate System Axis. Värikäs ikoni vasemmassa alakulmassa. Senhetkinen koordinaattisysteemi. Vaihtoehdot default global, maailman koordinaatistojärjestelmä ja käyttäjän määrittelemä.
  • Work Layer Indicator. Alhaalla vasemmalla. Sen hetkinen aktiivinen layer ja layereihin liittyvä menu. Piirtämiset ym. koskevat sitä Layeriä mikä on valittuna. Layereitä voi siis olla useita päällekkäin esittämässä eri asioita. Painamalla nuolia Layer kohdan sivuilla senhetkinen layer menee toisen taakse tai eteen. Tai paina Layer sanaa ja aukeaa valikko layereistä. Valikosta voi lisätä myös uusia Layereitä ja hallita vanhoja.

Työkalupaletit Tool Palettes[muokkaa]

  • Palkkeja joissa työkaluja. Voidaan avata mm. Window menusta tai painamalla hiirellä paletin ikonia ja pitämäällä painiketta painettuna, siirtymällä halutun ikonin päälle ja irroittamalla hiiren painike valinnan tekemiseksi. Avautunut palkki voidaan myös jättää auki vetämällä hiiri valikon läpi päästä päähän ja sitten tyhjään kohtaan ruudulla.
  • Käyttöliittymän voi tallentaa sen laiseksi kun se sillä hetkellä on valitsemalla File/Preferences/General/Save Now.

Osoitin Smart Pointer & Wireframe Tools[muokkaa]

  • Osoittimen muoto kuvastaa työkalua.
  • Fiksu osoitin ilmaisee useampivaiheisessa toiminnossa seuraavan vaiheen "kuuman kohdan"
  •  ? Offset (12)

Menu valikko Menu Bar[muokkaa]

Tiedostot File[muokkaa]

  • File / New Uusi tiedosto
  • Useita voi olla auki samanaikaisesti.
  • Eri tiedostoja voi liittää vetämällä liitettävän tiedoston hiirellä toisen avoinna olevan tiedoston päälle.
  • Open Avaa vanhan tiedoston siinä tilassa ja asetuksissa kun se tallennettiin.
  • Save tai cmd-S tallentaa tiedoston. Vain geometriset muutokset tiedostoon antavat mahdollisuuden tallentaa uudestaan.
    • tallenna riittävän usein, varsinkin ennen monimutkaisia muutoksia, koska niiden epäonnistuttua voi tiedoston jättää tallentamatta ja avata alkuperäisen uudestaan.
  • Save as Tallentaa tiedoston uudella nimellä. Tällä tehdään varmuuskopio manuaalisesti.
  • File / Preferences / Filling / Autosave mahdollisuus tehdä automaattinen varmuuskopiointi tietyin määritellyin välein. Tiedostot tallennetaan Cad-ohjelman kansioon nimeltä Backup.
  • Revert Tuhoaa kaikki tehdyt muutokset viimeisen tallennuksen jälkeen
  • Close Sulkee avoinna olevan tiedoston, jos muutettu pyytää tallentamaan ennen sulkemista.
  • Exit Sulkee ohjelman, jos muutettu tiedostoja pyytää tallentamaan ennen sulkemista, myös useamman aukiolevan tiedoston.

Edit[muokkaa]

  • Valitsee ja muokkaa objekteja.

Layout[muokkaa]

  • Määrittelevät piirtoalueen ja siihen liittyviä toimintoja

View[muokkaa]

  • Dokumentin näyttämiseen liittyviä komentoja

Planes[muokkaa]

  • Valitsee ja määrittää work plane.

Pen[muokkaa]

  • Kynän määrittely, muodot, värit, koot, nuolityypit, niiden päät jne.

Text[muokkaa]

  • Tekstin muoto

Dimension[muokkaa]

  • Määrittelee tarkkuuksia, muotoja ja toleransseja.

Verify[muokkaa]

  •  ? (18)

Window[muokkaa]

  • Työkalupalettien näkyvyys jne.

Help[muokkaa]

  • Ohjeet pdf-manuaaleihin www sivuilla ja tuki.

Piirtoalueen komennot[muokkaa]

  • Kun objekti on valittuna, toiminnot vaikuttavat siihen. Jos mitään objektia ei ole valittuna muutokset vaikuttavat kaikkiin aukioleviin tiedostoihin.
  • Toiminto voidaan keskeyttää esc -näppäimellä. Esc myös poistaa objektin valinnan ja toisen kerran painaminen palauttaa Selection eli nuoli työkaluvalinnan.
  • Hiiren oikealla näppäimellä tai ctrl ja hiiren vasen näppäin tuo valikon. Tyhjällä alueella painettuna tai objetin ollessa valittuna eri komennot (22-23)
  • Show/Hide Axis löytyy View menusta
  •  ? Show/Hide Work Plane löytyy Planes menusta
  • Show/Hide Points löytyy Edit menusta. Näyttää aktiivisen objektin kontrollointipisteet.

Piirtäminen todellisessa koossa Drawing at Full Scale[muokkaa]

  • Kun piirretään paljon yksityiskohtaisia asioita sisältäviä kohteita, olisi hyvä piirtää luonnollisessa koossa. Se on tällä ohjelmalla mahdollista. Kuva ainoastaan pienennetään näkymään halutun kokoisena. Virheet vähenevät. Etäisyydet säätyvät automaattisesti. Liitetyt etäisyydet päivittyvät kun objektia muutetaan. Ohjelmaan on helppo tuoda muita todellisessa koossa olevia kohteita.
  • Piirros voidaan sovittaa kirjoittimelle ja paperille sopivaksi kohdassa File / Page Setup.
  • Sivujen rajat voidaan laittaa näkymään.
  • Kaikki saadaan ruudulle näkymään View/Zoom All. Zoomaus eli tarkennus ei muuta todellista kohteen kokoa 1:1.

Ruudukko Grid[muokkaa]

  • View/Show Grid tuo ruudukon taustalle. Asetukset löytyvät Planes menusta. Ja pääasetukset Pref/Grid.
  • Window/Snap ja Snap Options valikosta To Grid ja geometriset pisteet tarttuvat lähimpään ruudukon risteyspisteeseen

2. Kaksiulotteisen kohteen luominen[muokkaa]

Piirrettyä kohdetta voi muokata tarpeen mukaan Status Line kohdilla.

Viivatyökalut Line Tools[muokkaa]

  • Pen -kohdassa määritellyt arvot vaikuttavat.
  • Kulma mitataan horisontaalisesta linjasta.

Viivan piirtäminen Single Line[muokkaa]

  • Kahden pisteen välille.
  • Klikkaa lähtöpiste ja klikkaa loppupiste
  • Status Line rivillä näkyy lähtöpisteen koordinaati xyz ja loppupisteen suhteelliset koordinaatit deltaxyz, viivan pituus ja kulma horisontista.
  • Uuden viivan piirtäminen kohtisuoraan olemassaolevaan. Liikuta hiirtä viivalla kunnes ilmestyy on -sana ja valitse haluamasi kohta viivalla. Klikkaa hiirtä. Vedä haluamasi viivan pituus ja käännä hiirtä kunnes ilmestyy teksti perpendicular. Klikkaa hiirtä loppupisteeksi. Samoin voit tehdä 45 asteen kulmat. Sekä tangentin "tanget" esimerkiksi ympyrän ulkopuolelle.

Viivan piirtäminen keskipisteestä Mid-Point Line[muokkaa]

  • Klikkaa viivan keskikohta ja vedä viiva halutunlaiseksi ja klikkaa lopetuskohta.

Yhdistetyt viivat Connected Lines[muokkaa]

  • Viivan lopetuskohta on seuraavan aloituskohta
  • Lopeta painamalla Esc tai klikkaamalla kahdesti lopetuspisteessä
  • Tangentiaalisen kaaren viimeisestä yhdistetystä pisteestä voi tehdä pitämällä option (alt) näppäintä alhaalla. Näitä voi tehdä peräkkäin pitämällä option näppäintä alhaalla tai jatkaa yhdistettyjä viivoja tekemällä. Kaaria ei voi editoita status riviltä.

Samansuuntainen viiva Parallel Line[muokkaa]

  • Valitse työkalu ja vedä hiiren painiketta alhaalla pitämällä haluamastasi viivasta kopio. Etäisyyden voi myös antaa Statusrivin Offset kohtaan.

Pisteet Point[muokkaa]

Valitse työkalu ja sitten paina Optio (Alt) näppäintä ja valitse haluamasilainen merkki.

  • Ylhäällä Message rivillä voi valita tehdäänkö pistemäisiä vai sarjoja objekteihin.
  • Pistevalinnassa piirustusalueelle voi tehdä klikkaamalla + x o tai ruutu merkkejä.
  • Sarjavalinnassa anna Statusriville pisteiden määrä. Klikkaa haluamaasi objektia kuten ympyrää ja tasaisin välein ilmestyy automaattisesti kehälle määrittelemäsi määrä merkkejä. Useampia voi samalla kertaa valita pitämällä shift-näppäintä alhaalla objekteja valittaessa.
  • Pintavalinnassa anna tiheys U ja V arvoihin. Valitse pinta tai pinnat. Pintaan ilmestyy ruudukko.

Seinä Smart Wall[muokkaa]

  • Tämä toiminto ei ole mahdollisesti paketissa tulevassa v4:ssä, mutta päivityksen saa ladattua http://downloads.imsidesign.com/TCMAC/TurboCAD-Mac-Deluxe-v4-1.dmg
  • Piirtää tuplaseinän joka on rakennusten piirtämisessä tarpeellinen. Samaan kerrokseen (layer) piirretyt sopivat toisiinsa automaattisesti
  • Sijaitsee päävalikon alimpana omana valikkonaan
  • Toimii oikein vain Top view tilassa.
  • Määritä status rivillä seinän paksuus. Klikkaa lopetuspisteet. Paina Shift kääntääksesi seinän vastakkaiselle sivulle. Jatka määrittelemäällä pisteitä tarpeen mukaan. (lue uudestaan 33)

Kaarityökalut Arc Tools[muokkaa]

  • Kaarien piirtämiseen
  • Center-point arc. Keskipisteen mukaan. Ensin keskipiste, sitten aloituspiste ja lopetuspiste.
  • 3-point arc. Aloituspiste, toinen piste kaarelle ja kolmannella haetaan koko. Pitämällä alt näppäimen alhaalla ja klikkaamalla olemassaolevaa objektia, kaari liittyy siihen.
  • Tangent-point arc. Aloitetaan piirtämällä halutun mittainen viiva kahdella ensimmäisellä klikkauksella josta tangentti syntyy ensimmäisen ja viimeisen klikkauksen välille.

Ympyrätyökalut Circle Tools[muokkaa]

  • Center-point circle. Kesikipisteen ja säteen mukaan.
  • Opposite-Point cicle. Halkaisijan mukaan.
  • 3-point circle. Kolmen pisteen mukaan. Alt näppäimellä tarraa aikaisempaan objektiin.
  • Tangent circle. Syötä ympyrän halkaisija Status-riville ensin. Klikkaa seuraavaksi kahta eri olemassaolevaa objektia. Ympyrä muodostuu näiden väliin. Alt näppäin siirtää vaihtoehtoiseen paikkaan.

Ellipsityökalut Ellipse Tools[muokkaa]

  • 2-point Center ellipse. Klikkaa keskipiste ja vedä ellipsille muoto.
  • Opposite-corner ellipse. Klikkaa toinen reuna ja klikkaa vastakkainen reuna.
  • 3-point center ellipse. Klikkaa keskipiste, sivun keskipiste ja kulma.
  • 3-corner ellipse. Klikkaa kulma, klikkaa toinen kulma, klikkaa kolmas kulma.

Polygon tools[muokkaa]

  • Kaikissa muissa paitsi Polygon from Curves, voidaan valita Single Line tai Smart Polygon. Single Line muodostuu yksittäisistä viivoista joita voidaan muokata itsenäisesti. Smart Polygon muodostaa piirretyn objektin kokonaisuudessaan. Jälkimmäiseen voidaan kohdistaa 3D komentoja, mutta ei 2D wireframe työkaluja. Jos näitä halutaan käyttää on objekti muutettava ensin viivoiksi Edit/Change Object type.
  • Valitse Rectangle ja ylhäältä haluttu piirtämistapa
  • Center Rectangle. Keskipiste ja yksi kulma määritellään
  • Corner Recgtangle. Suorakulma. Kaksi kulmaa määritellään.
  • Diagonal Rectangle. Määritellään kaksi vastakkaista kulmaa. Neliö saadaan kun hyväksikäytetääan vihjeviivaa joka ilmoittaa 45astetta.
  • Center/Axis Rectangle. Määritä keskipiste, sivun keskipiste ja haluttu koko.
  • Corner/Axis Rectangle. Määritä kaksi kulmaa ja vedä suorakulmio siitä.
  • Inscribed Polygon. Monikulmio. Määritä keskipiste ja haluttu koko. Status-rivillä, montako kulmaa kohdassa sides.
  • Circumscribed Polygon. Monikulmio, jonka säde/halkaisija on sivujen keskipisteen mukaan
  • Star Polygon. Tähti. Statusrivillä, sakaroiden määrä. Keskipiste, ulompipiste ja sisempi piste. Jos shift-näppäin, tähden saa epäsymmetriseksi, kierteelle.
  • Arbitary Polygon. Useamman vapaasti valitun pisteen mukainen monikulmio. Lopeta klikkaamalla aloituspistettä tai klikkaamalla kahdesti, jolloin viimeinen yhdistyy aloituspisteeseen.
  • Polygon from Curves. Tekee kaarista kuvioita. Valitse kaari tai useampia kaaria pitämällä shift-näppäintä alhaalla.

Spline Tools[muokkaa]

  • Kaaria, jotka ovat jouhevia, NURB (Non-Uniform Rational B-Splines). Jatkuvuus säilyy edellisissä kaarissa klikkauksen jälkeen.

Sekalaisia vinkkejä[muokkaa]

  • Viivoista piirretyn alueen voi Group -ryhmittää. Koska sitä ei voi fill -täyttää, vaan hatch-toiminnolla, niin määrittele hatch-toiminnossa viivojen vierekkäisyys esim. 0,1, jolloin tulos on yhtenäisempi.