HUOM! Voit itse lisätä ja muuttaa sisältöä muokkaa-painikkeiden avulla

 Olet itse vastuussa tämän teoksen käytöstä aiheutuvista vahingoista Lue lisää.

Office

Kohteesta Wikikko - kansan taitopankki
Loikkaa: valikkoon, hakuun

Makro[muokkaa]

  • Uusi makro
  1. Tools > Macro > Visual Basic Editor
  2. Insert > Module
  3. Kirjoita avautuvaan ikkunaan skripti
  4. Tallenna xlsm -muodossa koko excel-taulukko
  • Makron käyttäminen
    • Solussa viittaa makrofunktion nimeen, esim. =FunktionNimi(A1)
  • Hävinnyt Makron salasana
  1. Työkalut > Makro > Visual Basic Editor
  2. Avautuu ikkuna, jonka vasemmasta palkista avaa hakemistopuu näkyviin
  3. Etsi sieltä makro

Vinkkejä[muokkaa]

Officen käyttöliitymän kieli[muokkaa]

  • Officen valikot seuraavat sitä kielivalintaa, jota käytät OSX-käyttöjärjestelmäkielenä yleisesti. Jos haluat muuttaa jonkin Office-ohjelman kielen toiseksi kuin käyttöliittymäkielen, esimerkiksi englanniksi. Seuraava ohjelma poistaa ensisijaisena järjestelmäasetuksissa olevan kielen kielipaketin määrätystä office-ohjelmasta ja ottaa seuraavan kielipaketin listalla käyttöön. Asetuksen voi palauttaa taas takaisin, kun alkuperäistä kielipakettia ei tuhoa vaan vain nimeää kansion nimen toiseksi, jolloin Office ei tunnista sitä. Toiminto pitää tehdä jokaiselle Office-ohjelmalle erikseen. (Testattu Word for Mac v. 15.17 18.12.2015)
  1. Järjestelmäasetukset > Kieli ja alue > Ensisijaiset kielet 1. Suomi 2. English
  2. Lopeta Office ohjelmat.
  3. Finder > Ohjelmat > Microsoft Word.app päällä klikkaa hiiren oikeaa ja valitse Näytä pakkauksen sisältö > Contents > Resources > etsi hakemisto fi.lproj > nimeä tiedosto esimerkiksi xfi.lproj
  4. Käynnistä kyseinen ohjelma, jonka kohdalla teit muutoksen ja se on nyt englanniksi.

Excel[muokkaa]

F2[muokkaa]

F2 näppäin saa Windowsissa solun muokattavaksi, vastaava näppäin Applessa on ctrl-u

Funktiot[muokkaa]

Suomenkielisessä Excelissä on suonekieliset funktioiden nimet. Googlen ohjeet viittaavat esm. englannin kielisiin funktionimiin. Käännöstalulukoita:

http://excelohjeet.com/excel-funktiot-suomeksi-ja-englanniksi/
http://www.tekstiviestit.fi/sihteeriopas/sihteeriopas-materiaali-funktiot.html

Korvaavia taulukkolaskentaohjelmia[muokkaa]

  • Open Office / Calc taulukkolaskenta suomenkielisenä.

Postinumero[muokkaa]

Postinumerosarakkeesta häviävät etunollat. Sarakkeen solujen muoto täytyy muuttaa: Valitse postinumerosarake painamalla koko sarake ylhäältä painaen / paina hiiren oikeaa näppäint ja valitse sieltä Format Cells... / Number -välilehti / Category Special / Zip Code.

Rasti ruutuun[muokkaa]

  • Excel for Mac (2016):
  1. Excel > Preferences > View > In Ribbon, Show Developer tab
  2. Developer tab > Check Box

Solun lukitseminen[muokkaa]

Esim. (A1*$B$1) kaavaa kopioitaessa A1 muuttuu rivin mukaan, mutta B1 pysyy aina samana.

Tiedostosta UTF-8 tai UTF-16[muokkaa]

https://help.surveygizmo.com/help/encode-an-excel-file-to-utf-8-or-utf-16

Mac OSX[muokkaa]

  • Microsoft Excel: ei mahdollista.
  • OpenOffice (http://www.openoffice.org)
    • Save as type: Text CSV (.csv) > valitse Edit filter settings > Character set: Unicode (UTF-8)
  • LibreOffice (http://www.libreoffice.org): kyllä
  • Google Drive
    • Vedä hiirellä xls-tiedosto Google Driveen > File > Download as > Comma-separated values (.csv, current sheet).
  • Pääte

Tekstin jakaminen useaan soluun[muokkaa]

http://office.microsoft.com/en-001/excel-help/split-text-into-different-cells-HA102809804.aspx

URL-osoite linkistä[muokkaa]

  • Kun URL-osoite on solussa tekstin "takana"
  • Kirjoita Visual Basicissa seuraava funktio ja kirjoita tyhjään soluun =TulostaURL(tähän linkin sisältävän solu)
Public Function TulostaURL(c As Range) As String
    On Error Resume Next
    GetURL = c.Hyperlinks(1).Address
End Function

Vie solu lainausmerkeissä tekstitiedostoon[muokkaa]

  • Esim. "teksti","teksti"

Kirjoita Visual Basicissa seuraava funktio

Lähde: https://support.microsoft.com/en-us/help/291296/procedure-to-export-a-text-file-with-both-comma-and-quote-delimiters-i
Sub QuoteCommaExport()
   ' Dimension all variables.
   Dim DestFile As String
   Dim FileNum As Integer
   Dim ColumnCount As Integer
   Dim RowCount As Integer

   ' Prompt user for destination file name.
   DestFile = InputBox("Enter the destination filename" _
      & Chr(10) & "(with complete path):", "Quote-Comma Exporter")

   ' Obtain next free file handle number.
   FileNum = FreeFile()

   ' Turn error checking off.
   On Error Resume Next

   ' Attempt to open destination file for output.
   Open DestFile For Output As #FileNum

   ' If an error occurs report it and end.
   If Err <> 0 Then
      MsgBox "Cannot open filename " & DestFile
      End
   End If

   ' Turn error checking on.
   On Error GoTo 0

   ' Loop for each row in selection.
   For RowCount = 1 To Selection.Rows.Count

      ' Loop for each column in selection.
      For ColumnCount = 1 To Selection.Columns.Count

         ' Write current cell's text to file with quotation marks.
         Print #FileNum, """" & Selection.Cells(RowCount, _
            ColumnCount).Text & """";

         ' Check if cell is in last column.
         If ColumnCount = Selection.Columns.Count Then
            ' If so, then write a blank line.
            Print #FileNum,
         Else
            ' Otherwise, write a comma.
            Print #FileNum, ",";
         End If
      ' Start next iteration of ColumnCount loop.
      Next ColumnCount
   ' Start next iteration of RowCount loop.
   Next RowCount

   ' Close destination file.
   Close #FileNum
End Sub

Tekstin yhdistäminen kahdesta solusta yhteen soluun[muokkaa]

  • Myös OpenOffice
    • =A1 & ", " & A2 (tässä esimerkissä väliin tulee pilkku)
    • =A1 & " " & A2 (tässä esimerkissä väliin tulee yksi väli)

Tekstin/luvun käsittely[muokkaa]

Huom. Applessa käytä puolipistettä pilkun sijaan.

  • =RIGHT(A1; LEN(A1)-5) antaa tulokseksi 6789 kun solussa A1 on 123456789 eli näyttää oikealta kuudennesta merkistä lähtien.
  • =TRUNC(A1; 2) antaa tulokseksi 39,9 kun solussa A1 on 39,988 eli ei pyöristä.
  • =REPLACE(A1;3;1;".") antaa tulokseksi 12.456789 kun solussa A1 on 123456789 eli korvaa kolmannen merkin pisteellä.
  • =ROUND(A1;3) pyöristää kolmeen desimaaliin.
  • ="Teksti " & A1 & "teksti"
  • =ABS(A1) muuntaa negatiivisen luvunku positiiviseksi luvuksi

Tulostus[muokkaa]

Tulostettaessa eivät ilmesty solua pitemmät tekstit.

  • Solun formaatti/muoto saattaa olla väärin. Muuta esimerkiksi General

Vienti[muokkaa]

Useat nettisovellukset antavat mahdollisuuden viedä tietokannoissa olevia tietoja Excel-taulukko muotoon. Taulukon avaaminen ei kuitenkaan onnistu välttämättä ongelmitta.

Ääkköset ja Macintosh[muokkaa]

Avaa Excel ja tuo tiedosto seuraavan toiminnon kautta: File / Import... / CSV file / Delimited, File origin Windows (ANSI)

PowerPoint[muokkaa]

  • Kaatuu käynnistyessä kerta toisensa jälkeen kun valitset Retry kohdassa, jossa ohjelma varmistaa lisenssiä. Valitse sen sijaan: Remind me later. (Microsoft PpowerPoint for Mac, 2/2016)
  • Kaikkien diojen kielen muuttaminen: View > Outline view > Cmd-a > Tools > Language > valitse kieli > Ok

Diojen alkuun pikkuesitys[muokkaa]

Tilaisuuden alkaessa, osallistujien saapuessa voi laittaa pienen muutaman dian esityksen pyörimään taustalle, josta yhdellä klikkauksella pääsee varsinaisiin dioihin. Kaikki tehdään samassa PowerPoint-tiedostossa (9/2016)

  • 1. Diashown asetukset
  1. Järjestä esityksen alkuun ne diat, joita haluat pyörittää introna
  2. valitse diat pitämättä cmd-painiketta alhaalla
  3. valitse välilehti Transitions
    1. valitse After -kohtaan monenko sekunnin välein dia automaattisesti vaihtuu
    2. poista valinta kohdasta On Mouse Click
  4. valitse välilehti Slide Show > Set Up Slide Show
    1. valitse Loop continuously until 'Esc'
    2. All
    3. Using timings, if present.
  • 2. Siirtyminen esitykseen painike
  1. Valitse välilehti Insert > Shapes > Action Buttons > sopivan näköinen painike, esim. talokuvake
    1. vedä se hiirellä muotoonsa diaan haluamaasi kohtaan
    2. avautuu painikkeen Action Settings
      1. valitse Hyperlink to ja alasvetovalikosta se dia josta haluat varsinaisen esityksen alkavan
  2. säädä tarvittaessa painikkeen kokoa ja paikkaa
  3. tee painike tarvittaessa näkymättömäksi, kts. kohta 2.1
  4. kopioi painike muihin introdioihin, jolloin voit siirtyä mistä introdiasta tahansa varsinaiseen esitykseen
  5. myöhemmin, jos haluat muuttaa, aloitusdiaa, valitse hiiren oikean painikkeen valikosta Hyperlink > Edit Hperlink... > Slide... Kuvake täytyy tämän jälkeen taas kopioida kaikkiin introdioihin.
    • 2.1 Painikkeen muuttaminen näkymättömäksi (valinnainen)
  1. Klikkaa painiketta hiirellä kaksi kertaa, avautuu Format Picture-sivupalkki
  2. valitse Shape Options > Fill > Picture or texture fill
  3. vedä Transparency 100 prosenttiin sekä Fill että Line kohassa, jolloin kuvake häviää näkyvistä
  4. muista kuvakkeen sijainti ;)
  • 3. Muiden diojen piilottaminen ja lopetusdia

Vaikka kaikki diat piilotetaan, ne kuitenkin näkyvät normaalisti diaestyksessä.

  1. Paina mieleesi viimeinen dia tai tee "kiitos"-dia, jotta tiedät minkä dian jälkeen et enää paina seuraavaa diaa, jolloin alkaisi automaattinen aloitusintro pyörimään
  2. valitse kaikki varsinaisen esityksen diat klikkaamalla ensimmäistä ja sitten klikkaamalla viimeistä samalla kun pidät shift-näppäintä alhaalla
  3. klikkaa hiiren oikeaa painiketta ja valitse Hide Slide
  • 4. Dian vaihtumisaika ja tapa (valinnainen)
  1. Säädä tarvittaessa introdiojen vaihtumistapa ja vaihtumisaika Transitions-valikosta.
    1. esimerkiksi Fade ja Duration 03,00 sekuntia
  • 5. Käyttö
    • Aloita normaalisti diaesitys valitsemalla joku introdioista
    • paina painiketta kun haluat siirtyä introsta varsinaiseen esitykseen
    • älä paina viimeisen dian jälkeen esityksen alkuun, koska se aloittaa intron
Lähde http://www.techrepublic.com/blog/microsoft-office/add-a-looping-introduction-to-a-powerpoint-presentation/

Sisällysluettelo[muokkaa]

Diojen otsikot saa seuraavasti:

  1. View > Outline View
  2. Hiiren oikea painike > Collapse > Collapse All
  3. Valitse kaikki otsikot Cmd-a, cmd-c
  4. Liitä diaan tai word-asiakirjaan tms. Cmd-v

Word[muokkaa]

  • Jos jotain on faktaa, niin se että Word kaatuu aivan varmasti! Tästä syystä kannattaa asettaa automaattinen tallennus tapahtumaan minuutin välein. (2018)

Bugeja[muokkaa]

  • Alkaa ilmoittamaan että Global Normal.dotm ei voida lukea tai kirjoittaa, eikä docx-loppuisia tiedostoja pysty ollenkaan avaamaan. Korjaantuu uudelleenkäynnistämällä tietokone. Finderin relaunch (Force quit) tai Officen sulkeminen eivät auta. Eikä myöskään Normal.dotm tiedosto-oikeuksien muuttaminen. (2/2016)
  • There is a serious disk error on file ~Word Work File S{A769D74A-0F0E-0249-8302-DB7F18298A6B}.tmp.
    • Katso, että Preferences > File Locations > AutoRecover Files -polku on olemassa.
    • Aja Disk Utility > First Aid.

Kenttä (field)[muokkaa]

  • Esimerkiksi päivämäärä tai sisällysluettelo, joka päivitetään hiiren oikean painikkeen kautta.
  • Kentän koodin saa näkyviin Mac tietokoneessa hiiren oikeasta painikkeesta Toggle Field codes tai alt-f9. Koodin saa suljettua alt-f9. Näppäinyhdistelmän toimintaan saamiseksi aseta tietokoneen System Preferences > Keyboard > Use F1, F2, etc. keys as standard function keys.
  • Kenttä alkaa ja päättyy mustiin { ja } -merkkeihin. Niiden sisälle tulee toiminnon suorittava koodi. Huomaa, että shift-alt-( tuotetettu { ei ole tällainen aloittava tai lopettava merkki vaan muodosta kenttä ensin vaikka päivämääräksi ja muokkaa sitten sisältöä.
  • Koodin lisäämisen jälkeen päivitä kenttä normaalisti hiiren oikean painikkeen kautta.
  • Error! Digit expected. -virheilmoitus: Saattaa liittyä järjestelmäasetusten päivämäärien muotoon, desimaaliin, tuhaterottimeen, kielivalintaa tms.

AutoText[muokkaa]

  • Esitalletetun tekstin, kuvien ym. lisääminen.

Vinkkejä[muokkaa]

  • Autorecovery. Kun Word kaatuu, se usein tarjoaa viimeisintä työtä uudelleen avattavaksi. Jos näin kuitenkaan ei tapahdu ja yrität avata manuaalisesti docx -tiedostoa, jonka Word on automaattisesti tallentanut taustalla, mutta saat virheilmoituksen. Vaihda tällöin tiedostopäätteeksi .asd jolloin sen todennäköisesti aukeaa.
  • Alaviite
    • Mac:ssa Option-Command-f
    • Ristiviite. Esimerkiksi kun alaviitteen tekstissä halutaan viitata toiseen alaviitenumeroon, joka sitten päivittyy kun lisätään uusia alaviitteitä. Viittaus-välilehdellä on kohta Ristiviite, josta viittaus lisätään. Ristiviitteet päivitetään alaviitteissä cmd-a (valitse kaikki alaviitteen tekstit) ja painamalla F9 (fn-F9). Tekstissä ristiviitteet päivitetään vastaavasti valitsemalla teksti ja F9 (fn-F9) tai hiiren oikean näppäimen valikosta Päivitä kenttä -kohdasta.
    • Seuraava on korjattu viimeisimmässä päivityksessä 12/2015: Vaikka alaviitteen tyyli olisi säädetty esimerkiksi englanniksi, alaviitteiden kieli seuraa OSX-käyttöjärjestelmän järjestelmäasetusten Näppäimistö > Syöttölähteet -kohdassa määriteltyä kieltä. Jos esimerkiksi käytät käyttöjärjestelmään suomen kielellä, mutta kirjoitat alaviitteitä englanniksi, täytyy lisätä englannin kieli järjestelmäasetuksissa ja vaihtaa näppäimistö Wordin käytön ajaksi englannin kielelle. Tämä sujuu helpoiten asettamalla lipun kuvake näkyville kuvaruudun ylälaitaan kellon vierelle.
  • 2 napautusta hiirellä vasemmalla puolen valitsee kappaleen
  • 3 napsautusta hiirellä vasemmalla puolen valitsee koko tekstin
  • kun muutat reunusta viivaimissa painamalla samalla ALT niin tulee senttimetreinä näkyviin.
  • sarkaimia säädät valitsemalla halutunlaisen sarkaimen ja painamalla sen haluttuun kohtaan viivaimella.
  • asiakirjan sijainnin levyllä ilmoittavan kentän päivitys F9 kentän päällä. Ctl + F11 lukitsee kentän.
  • Sisällysluettelo. Käytä tyyleinä valmiita otsikkoja, jotka muokkaat tekstiä kirjoittaessasi. Kun teet sisällysluettelon, Word ottaa käyttöön Sisluet 1 jne. tyylit, jotka muotoilevat sisällysluettelon. Jotta saa eri osiot samaan sisällysluetteloon, käytä esimerkiksi lähteille ja lyhenteille ensimmäistä Otsikko -tyyliä ja seuraavassa osiossa, varsinaisessa tekstissä aloita Otsikko 1:stä, joka on ensimmäisen tason otsikko ja siitä sitten eteenpäin. Älä kuitenkaan merkitse Otsikko tyyliin sisällysluettelon otsikkoa, koska sen ei välttämättä kuulu sisältyä sisällysluetteloon. Eikä myöskään lähteiden alaotsikot.
Otsikko: LÄHTEET
Otsikko 1: 1 OTSIKKO
Otsikko 2: 1.1 Otsikko 
Otsikko 3: 1.1.1 Otsikko'
  • Kirja
    • Layout > Margins > Custom Margins...
    • Multiple Pages: Book fold
    • Aseta reunukset, esim. 1,2 cm sekä gutter eli sivujen väli, esim. 0,5 cm.
    • Page Setup... > Orientation: Landscape > Paper Size A4
    • Sivut näkyvät ruudulla yksittäin, mutta tulostettaessa ilmestyvät kirjaksi. Tulosta paperin kummallekin puolelle. Siirrä tulostunut paperi samassa asennossa uudestaan tulostettavaksi, älä siis käännä 180 astetta. Tarvittaessa Manually Print on Both Sides -valinnalla ja "flip the sheets on the short edge of the paper".
    • https://support.office.com/en-us/article/create-a-booklet-or-book-dfd94694-fa4f-4c71-a1c7-737c31539e4a
  • Luettelo päivitetään Hiiren oikea näppäin luettelon päällä / Päivitä kenttä / Päivitä koko luettelo
  • Numerointi. Numeron ja tekstin väli ei säädy sopivaksi. Valitse rivin päällä Kappale / Sarkaimet ja aseta sarkaimeksi esim. 0,6 cm.
  • Osio. Osiot koostuvat sivuista. Osiot voivat olla esimerkiksi eritavoin sivunumeroituja, jolloin ne näkyvät sisällysluettelossa myös eri numeroinnilla.
  • Monitasoinen luettelo. Jos numerot eivät kerta toisensa jälkeen asetu:
  1. Nollaa koko asiakirjan luettelot asettamalla jokaiselle tyyllille luettelokohdan valinta none
  2. valitse asiakirjan ensimmäinen otsikko ja Home-valikosta monitasoinen luettelo 1 ja 1.1 ja 1.1.1. Tästä tulee nyt koko asiakirjan luettelo.
  3. valitse seuraava otsikko ja taas monitasoinen luettelo, mutta valitse nyt Current list ja sitten tab-näppäimellä siirrä se oikeaan kohtaan. Jos ei onnistu, niin maalaa edellinen otsikkotyyli telalla ja näin monista se seuraavaan.
  4. muokkaa tyyliä valitsemalla hiiren oikea numeroiden päällä ja valikosta Bullets and Numbering... koska tyylin muokkaminen ei välttämättä avaa "oikeaa" luetteloa.
  • Sivunumerot
    • Jokainen osio (section) voi jatkaa edellistä sivunumeroa tai olla omansa.
    • Jokainen osion ensimmäinen sivu voi olla ilman näkyvää sivunumeroa. Insert > Header > Edit header > Different First Page
  • Korostetun tekstin valinta
    • Avaa Find-ikkuna, josta saat auki Advance > Valitse Highlight all items found in: Maind Document > Find Format Highlight > Sulje hakuruutu > Ctrl-c

Fonttikoko[muokkaa]

  • 1 tuuma (2,54 cm) pitäisi olla 72

Muutosten sisällyttäminen kopiossa toiseen dokumenttiin[muokkaa]

Word 2010[muokkaa]

  • Kytke pois seuranta-toiminto
  • Valitse teksti, joka kopioidaan
  • Paina Ctrl - F3
  • Siirry kohdeasiakirjaan ja paina Ctrl - Shift - F3
Google: how to copy word track changes 2010
Lähde: http://rlab-it-blog.blogspot.fi/2009/07/how-to-copy-text-from-word-document-and.html

Sanasto[muokkaa]

Sanojen lisääminen sanastoon saattaa olla estynyt. Lisää... –painike näkyy harmaana. Tämä ehkä johtuu siitä, että olet päivittänyt Officen ja jokin bugi estää tämän. Tämän voi korjata lisäämällä asetuksissa uuden sanaston. Se kannattaa esimerkiksi sijoittaa johonkin helposti löydettävään hakemistoon, josta se on lisättävissä johonkin toiseen Word-asennukseen tulevaisuudessa ja siirtyy siis varmuuskopioiden mukana.

RefWorks[muokkaa]